Re: [Chrysler300] Leaking Power Steering Pump
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chrysler300] Leaking Power Steering Pump





if it's like the one on my 61's and 62's, there is a large o-ring that goes around the front of the pump that is supposed to seal the front lip of the reservoir.  It usually is supplied in the rebuild kit. 

On Tue, Jun 14, 2016 at 2:20 PM, Donald Nissen fast-ace@xxxxxxxxxxx [Chrysler300] <Chrysler300-noreply@xxxxxxxxxxxxxxx> wrote:
 

Hi all, I need some help from the 300K experts, or anyone who knows.
My pump is leaking, small so far. It is not from front seal behind the
pulley. It is also not from either hose. It seems to be wet on the
bottom of were the reservoir meets the pump. Does this mean it is
leaking from the rear of the pump, and the pump needs replacing or is it
the seal between the two? Or is it impossible to tell? All the
rebuilders I have checked so far supply the pump without reservoir and
pulley. Otherwise the power steering is fine-just annoying leak & I
want to get this fixed before Elkhart. Any help greatly appreciated.

Don Nissen, 300K




--
"A government big enough to give you everything you want, is big enough to take away everything you have." ... Thomas Jefferson 


__._,_.___

Posted by: John Nowosacki <jsnowosacki@xxxxxxxxx>


To send a message to this group, send an email to:
Chrysler300@xxxxxxxxxxxxxxx

To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
go to https://groups.yahoo.com/neo/groups/all/manage/edit

For list server instructions, go to http://www.chrysler300club.com/yahoolist/inst.htm

For archives go to http://www.forwardlook.net/300-archive/search.htm#querylang




Visit Your Group
Yahoo! Groups
PrivacyUnsubscribeTerms of Use

__,_._,___


Home Back to the Home of the Forward Look Network Archive Sitemap