Re: [Chrysler300] Imperial Services - Has Anyone Received Their Products
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chrysler300] Imperial Services - Has Anyone Received Their Products Lately?





I had a flaky interaction over their 727 to push button adapter . Erratic or no answer , then site said temporarily closed . Unstable place for some reason . For whatever that is worth . 

Sent from my iPhone

On Oct 22, 2016, at 6:44 PM, cbilter@xxxxxxxxx [Chrysler300] <Chrysler300-noreply@xxxxxxxxxxxxxxx> wrote:

Hello all,  I talked to Steve at Imperial Services over 3 weeks ago and ordered a new transmission mount for my 300J.  He said it only takes a day to make it.  He was very prompt at taking my PayPal payment.  Since then – nada, ziltch, nitchts, nothing.  Phone is never answered, messages never returned, emails not responded to.  Has anyone received anything from this dude in the last month or so?  My patience is running on empty.

 

Carl Bilter

 

 



__._,_.___

Posted by: John Grady <jkg@xxxxxxxxxxxxxxxxx>


To send a message to this group, send an email to:
Chrysler300@xxxxxxxxxxxxxxx

To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
go to https://groups.yahoo.com/neo/groups/all/manage/edit

For list server instructions, go to http://www.chrysler300club.com/yahoolist/inst.htm

For archives go to http://www.forwardlook.net/300-archive/search.htm#querylang





__,_._,___


Home Back to the Home of the Forward Look Network Archive Sitemap