RE: Mopar Performance electronic distributor pulsing
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Mopar Performance electronic distributor pulsing



The erratic amp meter was the key - Toth Performance replied that I need a constant output voltage regulator.  Sounds like something that would be good regardless of ignition system – notes from the Jegs site:

 

>For 1969 and older engines using an electronic ignition conversion kit.

>Voltage is held steady at 13.5 volts compared to production regulators which fluctuate between 11.5 to 13.5 volts.

 

http://www.jegs.com/i/Mopar+Performance/312/P3690732/10002/-1

 

http://www.summitracing.com/parts/dcc-3690732

 

 

 

From: 1962to1965mopars@xxxxxxxxxxxxxxxx [mailto:1962to1965mopars@xxxxxxxxxxxxxxxx] On Behalf Of carverex@xxxxxxx
Sent: Saturday, May 23, 2015 4:28 AM
To: 1962to1965mopars@xxxxxxxxxxxxxxxx
Subject: Re: Mopar Performance electronic distributor puling

 

Hi Ric

 

You may want to check grounding of the module. I have one of these on my Fury, and it got jostled loose on the fenderwell. The car ran poorly for a while and then just wouldn't run. I finally identified the module as the problem. The instructions don't stress the importance of grounding! I sanded a bare spot on the mounting flange of the module and ran a ground to the block. Problem solved.

 

Good Luck! Let us know.......

 

Lyle

On Friday, May 22, 2015 at 8:41:53 AM UTC-4, Plucked Chicken wrote:

Installed a new Mopar Performance electronic distributor last night.  Starts and idles fine but going down the road while holding steady throttle, the engine pulses up and down every few seconds.  Almost like you are giving it more and less throttle.  The amp meter is also erratic now.

 

Per the instructions the blue wire is connected to the ballast resister ignition feed side.  Black wire to neg side of coil.  And timing to 5 BTDC per the instructions.

I did notice the reluctor and pick-up are not parallel for the .008 gap.  All the same gaps as you spin it, and I did set the closest point to .008. 

Any ideas what the problem is?   Is there another vacuum advance type distributor to consider for electronic ignition?  Pertronix makes one I see that is an all-in-one unit, any other makers for 318 Poly?

I put the original point distributor back on for now, and it runs fine.

Thanks,

Ric

 

--
--
--
Please address private email -- email of interest to only one person -- directly to that person. That is, email your parts/car transactions and negotiations, as well as other personal messages, only to the intended recipient. Do not just press "reply" and send your email to everyone using the general '62-'65 Clubhouse public email address. This practice will protect your privacy, reduce the total volume of mail and fine-tune the content signal to Mopar topic. Thanks!
 
1962 to 1965 Mopar Clubhouse Discussion Guidelines:
http://www.1962to1965mopar.ornocar.org/mletiq.html and http://www.1962to1965mopar.ornocar.com/general_disclaimer.html.
--
You received this message because you are subscribed to the Google Groups "The 1962 to 1965 Mopar Mail List Clubhouse" group.
http://groups.google.com/group/1962to1965mopars?hl=en.

---
You received this message because you are subscribed to the Google Groups "The 1962 to 1965 Mopar Mail List Clubhouse" group.
To unsubscribe from this group and stop receiving emails from it, send an email to 1962to1965mopars+unsubscribe@xxxxxxxxxxxxxxxx.
For more options, visit https://groups.google.com/d/optout.

--
--
--
Please address private email -- email of interest to only one person -- directly to that person. That is, email your parts/car transactions and negotiations, as well as other personal messages, only to the intended recipient. Do not just press "reply" and send your email to everyone using the general '62-'65 Clubhouse public email address. This practice will protect your privacy, reduce the total volume of mail and fine-tune the content signal to Mopar topic. Thanks!
 
1962 to 1965 Mopar Clubhouse Discussion Guidelines:
http://www.1962to1965mopar.ornocar.org/mletiq.html and http://www.1962to1965mopar.ornocar.com/general_disclaimer.html.
--
You received this message because you are subscribed to the Google Groups "The 1962 to 1965 Mopar Mail List Clubhouse" group.
http://groups.google.com/group/1962to1965mopars?hl=en.

---
You received this message because you are subscribed to the Google Groups "The 1962 to 1965 Mopar Mail List Clubhouse" group.
To unsubscribe from this group and stop receiving emails from it, send an email to 1962to1965mopars+unsubscribe@xxxxxxxxxxxxxxxx.
For more options, visit https://groups.google.com/d/optout.


Home Back to the Home of the Forward Look Network