The Forward Look Network
The Forward Look Network
Search | Statistics | User Listing Forums | Chat | eBay | Calendars | Albums | Skins | Language
You are logged in as a guest. ( logon | register )

57 Imperial - power windows stopped working
Jump to page : 1
Now viewing page 1 [50 messages per page]
View previous thread :: View next thread
   Forward Look Technical Discussions -> Electrical, Battery and ChargingMessage format
 
imperial2100
Posted 2018-07-07 8:35 AM (#566193)
Subject: 57 Imperial - power windows stopped working


Veteran

Posts: 135
10025
I had a starter/battery issue and after replacing the starter, cables and battery, the windows do not work anymore. Neither the master switch or the single switches work, so it's something electrical.

I have been searching around on this car and I cannot find a fuse box of any kind.

Are there fuses for the power windows?

Any other suggestions on what it might be?
Top of the page Bottom of the page
Old Ray
Posted 2018-07-07 9:22 AM (#566198 - in reply to #566193)
Subject: RE: 57 Imperial - power windows stopped working



Extreme Veteran

Posts: 309
100100100
Location: Invermere B.C. Canada - Rocky Mountains
Hum....so you changed the starter and cables...and now the windows do not work? This might be a cause and effect situation.
Good chance that the power feed to the windows did not get connected somehow , time for a test light and a shop manual ?
Top of the page Bottom of the page
imperial2100
Posted 2018-07-07 9:39 AM (#566200 - in reply to #566198)
Subject: RE: 57 Imperial - power windows stopped working


Veteran

Posts: 135
10025
Old Ray - 2018-07-07 10:22 AM

Hum....so you changed the starter and cables...and now the windows do not work? This might be a cause and effect situation.
Good chance that the power feed to the windows did not get connected somehow , time for a test light and a shop manual ? :)

I tried looking up the wiring in a diagram for this car, but can't find any mention of window motor. I'm not even sure which color wire to begin tracing down. Haven't taken door panel off yet, but it may come down to that.
Top of the page Bottom of the page
Old Ray
Posted 2018-07-07 10:46 AM (#566210 - in reply to #566200)
Subject: RE: 57 Imperial - power windows stopped working



Extreme Veteran

Posts: 309
100100100
Location: Invermere B.C. Canada - Rocky Mountains
imperial2100 - 2018-07-07 7:39 AM I tried looking up the wiring in a diagram for this car, but can't find any mention of window motor. I'm not even sure which color wire to begin tracing down. Haven't taken door panel off yet, but it may come down to that.


NO. The odds that the window motors (plural) would both stop working (break) at the same time as you are replacing the starter etc. is unlikely, unless the input power source has been interpreted.
I think you should start at the other end (input power) of the problem.
Top of the page Bottom of the page
imperial2100
Posted 2018-07-07 3:44 PM (#566224 - in reply to #566210)
Subject: RE: 57 Imperial - power windows stopped working


Veteran

Posts: 135
10025
Old Ray - 2018-07-07 11:46 AM
NO. The odds that the window motors (plural) would both stop working (break) at the same time as you are replacing the starter etc. is unlikely, unless the input power source has been interpreted.
I think you should start at the other end (input power) of the problem.

I agree, as all the windows were working fine just 2 days ago. I would start on the battery side, but I don't know what wire is for the windows from the engine bay. I'm guessing at this point there is a master positive wire leading through the firewall and then that likely splits up to everything inside the car, such as radio, windows, seats, etc.

But I cannot find any diagrams that mention how the windows are wired in order to follow wire colors. All I can find is a generic diagram that has no mention of power windows or window motors.

I did pull the driver side switch panel and did a continuity test from the removed positive battery cable to the points on the window switch panel. All of the up and down points have continuity, but the main (center) point that provides power through the switches when they are "switched" is not connected. THIS IS THE PROBLEM

So now to trace this wire back through the car to find out where the disconnect is. For now though, I think I'm going to hard wire the switches straight from the batter in order to get these windows back down. Having them stuck in the up position sure does make for a very hot ride.
Top of the page Bottom of the page
imperial2100
Posted 2018-07-07 5:13 PM (#566230 - in reply to #566224)
Subject: RE: 57 Imperial - power windows stopped working


Veteran

Posts: 135
10025
Doing visual tracing and continuity tests, traced the main wire back through the firewall and to the battery. It was not connected and dangling down in the engine bay. I must have missed it when redoing all the wires when changing the main cables, battery, and starter. So stupid miss on my part. It was a black wire, likely 12 gauge or so that was running everything. (lighters, power seats, power windows)

Had originally confused it with another black wire that I found was simply tied off under the dash near a mounting bracket - that was likely used for some add-on that needed the 12v power.

Anyway, windows are back down and I can cruise in style again.
Top of the page Bottom of the page
imopar380
Posted 2018-07-08 12:26 AM (#566253 - in reply to #566230)
Subject: Re: 57 Imperial - power windows stopped working



Expert 5K+

Posts: 6751
500010005001001002525
Location: Victoria, BC, on Vancouver Island, Canada
Glad the window issue was a simple one!!
Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [50 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread



(Delete all cookies set by this site)