The Forward Look Network
The Forward Look Network
Search | Statistics | User Listing Forums | Chat | eBay | Calendars | Albums | Skins | Language
You are logged in as a guest. ( logon | register )

1958 Belvedere Power Steering Problem
Jump to page : 1
Now viewing page 1 [50 messages per page]
View previous thread :: View next thread
   Forward Look Technical Discussions -> Steering and SuspensionMessage format
 
furvedere
Posted 2018-08-08 7:49 AM (#568057)
Subject: 1958 Belvedere Power Steering Problem



Veteran

Posts: 250
1001002525
Location: Rochester, NY
I have a 1958 Belvedere that has a 1964 318 in it. I have reason to believe it's 1733496 Thompson Power Steering Pump is off the original 318 that came in the car. I have power steering at cruising speed but at idle there's no assist at all. Has anyone seen a pump slowly fail like this? Anyways, I can't seem to find a replacement anywhere and before I remove it and send it off to a rebuilder, I thought I'd check here to see if anyone has any suggestions or if anyone may have a known good replacement pump.

Thanks, Bob

PS...I hesitate sending it off to a rebuilder because I know I could hear back that it's not rebuildable.

Edited by furvedere 2018-08-08 10:08 PM
Top of the page Bottom of the page
Shep
Posted 2018-08-08 9:41 AM (#568061 - in reply to #568057)
Subject: Re: 1958 Belvedere Power Steering Problem



Expert

Posts: 3087
20001000252525
Location: Chestertown, NY ( near Lake George)
Has this been a slow deteroration? If so sounds like it could be a pump issue, without a pressure test, hard to be sure.
Top of the page Bottom of the page
furvedere
Posted 2018-08-08 10:09 PM (#568100 - in reply to #568057)
Subject: Re: 1958 Belvedere Power Steering Problem



Veteran

Posts: 250
1001002525
Location: Rochester, NY
I bought the car in early 2015. It had the problem when I got it. 3+ years later it seems like it's getting worse.
Top of the page Bottom of the page
Shep
Posted 2018-08-09 7:54 AM (#568118 - in reply to #568100)
Subject: Re: 1958 Belvedere Power Steering Problem



Expert

Posts: 3087
20001000252525
Location: Chestertown, NY ( near Lake George)
To be sure a pressure test should be done, or you could try flushing the system, the symptoms do point to a pump issue.
Top of the page Bottom of the page
ttotired
Posted 2018-08-09 5:39 PM (#568147 - in reply to #568057)
Subject: Re: 1958 Belvedere Power Steering Problem



Expert 5K+

Posts: 8263
5000200010001001002525
Location: Perth Australia
I would be surprised if a ps pump was hard to find in the US, I have at least 1 here in Aus for the 60 (I know its different)

Theres one on ebay now for your car, but pretty sure someone on here would have one kicking around

https://www.ebay.com/itm/1957-1958-Chrysler-Plymouth-USED-Thompson-p...

It does sound like a pump or slipping belt (you don't always here them) or its leaking internally in the box, but I doubt that

Top of the page Bottom of the page
furvedere
Posted 2018-08-09 9:40 PM (#568164 - in reply to #568147)
Subject: Re: 1958 Belvedere Power Steering Problem



Veteran

Posts: 250
1001002525
Location: Rochester, NY
ttotired - 2018-08-09 5:39 PM

I would be surprised if a ps pump was hard to find in the US, I have at least 1 here in Aus for the 60 (I know its different)

Theres one on ebay now for your car, but pretty sure someone on here would have one kicking around

https://www.ebay.com/itm/1957-1958-Chrysler-Plymouth-USED-Thompson-p...

It does sound like a pump or slipping belt (you don't always here them) or its leaking internally in the box, but I doubt that



I saw that pump on ebay...but its obviously a gamble to buy it. Not tested, could be junk/not rebuildable. I always thought you could hear a slipping belt. I know it's tight, but I'll check it. Thank you
Top of the page Bottom of the page
rebel
Posted 2018-08-10 12:19 PM (#568194 - in reply to #568164)
Subject: Re: 1958 Belvedere Power Steering Problem


Veteran

Posts: 192
100252525
Location: Western Colorado
I know Don Petty (wildone770) in Arizona has at least one of these pumps. Call him at 602-689-9414
Bob
Top of the page Bottom of the page
furvedere
Posted 2018-08-11 9:07 PM (#568264 - in reply to #568057)
Subject: Re: 1958 Belvedere Power Steering Problem



Veteran

Posts: 250
1001002525
Location: Rochester, NY
Thank you...I'll give him a call.

Bob
Top of the page Bottom of the page
furvedere
Posted 2018-08-30 9:45 AM (#569252 - in reply to #568057)
Subject: Re: 1958 Belvedere Power Steering Problem



Veteran

Posts: 250
1001002525
Location: Rochester, NY
No reply from Don Petty...perhaps I've come to a dead end with this 1733496 Thompson pump, unless I want to take a chance and see if someone can rebuild it. Here's my second option. Find another pump that will fit on this 1964 poly 318 motor....which will include getting the correct bracket, pulley to mount it/get the belt to line up. And also to to have enough room to adjust belt tension/avoid interference with the hoses. Can anyone help/advise me what other pumps will work? Thank you, Bob
Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [50 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread



(Delete all cookies set by this site)