The Forward Look Network
The Forward Look Network
Search | Statistics | User Listing Forums | Chat | eBay | Calendars | Albums | Skins | Language
You are logged in as a guest. ( logon | register )

Installed a Jiffy Jet Washer System
Jump to page : 1
Now viewing page 1 [50 messages per page]
View previous thread :: View next thread
   Forward Look NON-Technical Discussions -> 1955-1961 Forward Look MoPar General DiscussionMessage format
 
imopar380
Posted 2019-03-16 8:07 PM (#579437)
Subject: Installed a Jiffy Jet Washer System



Expert 5K+

Posts: 6854
500010005001001001002525
Location: Victoria, BC, on Vancouver Island, Canada
Today I replaced my non-working Trico Co-ordinated Washer System with the much simpler Jiffy Jet system. My Trico system has broken parts, a vacuum leak and parts are pretty much unobtainable. This system was used only on US built 1960 Chrysler and Imperial, plus 1958-1962 Corvettes and a few Cadillacs. The Jiffy Jet was used previous to 1960 and then again in 1961 and later. It's much simpler although the washers aren't coordinated to turn on the wipers when you press the button. This is the first time my washers have worked since i bought the car in 2008. I had a Jiffy Jet electric pump and a friend gave me the washer bag. He has collected an assortment of them over the years from parts cars. This setup is identical to the setup in his 1961 Saratoga. The electric pump was mounted at the bottom of the core support just in line with the bottom of the washer bag. I also ran all new hoses from the bag to the washer nozzles and a new "T" joint where the line separates to go to the nozzles. The bag took a lot of scrubbing with a Scotch Brite pad to get it looking this good.

Edited by imopar380 2019-03-16 8:12 PM




(March-16-#2.jpg)



(March-16-#1_-resize.jpg)



(20190302_161033_resized.jpg)



(20190302_161041_resized.jpg)



(20190302_202929_resized_InPixio.jpg)



Attachments
----------------
Attachments March-16-#2.jpg (250KB - 11 downloads)
Attachments March-16-#1_-resize.jpg (190KB - 11 downloads)
Attachments 20190302_161033_resized.jpg (313KB - 11 downloads)
Attachments 20190302_161041_resized.jpg (360KB - 11 downloads)
Attachments 20190302_202929_resized_InPixio.jpg (214KB - 11 downloads)
Top of the page Bottom of the page
miquelonbrad
Posted 2019-03-19 10:04 AM (#579528 - in reply to #579437)
Subject: Re: Installed a Jiffy Jet Washer System



Expert

Posts: 1663
10005001002525
Location: Hay Lakes, Alberta, Canada
Nice Ian!

My Cadillac has the co-ordinated Trico system. I've rebuilt it twice; it's only worked right for a few months at most in the 19 years I've owned the car...
Top of the page Bottom of the page
Ev's62Chrysler
Posted 2019-03-19 12:14 PM (#579537 - in reply to #579437)
Subject: Re: Installed a Jiffy Jet Washer System



Veteran

Posts: 144
10025
Location: Suwanee, GA
I have that same pump on my 65 Mustang.
Top of the page Bottom of the page
imopar380
Posted 2019-03-19 7:36 PM (#579561 - in reply to #579537)
Subject: Re: Installed a Jiffy Jet Washer System



Expert 5K+

Posts: 6854
500010005001001001002525
Location: Victoria, BC, on Vancouver Island, Canada
Ev's 62Chrysler - 2019-03-19 9:14 AM

I have that same pump on my 65 Mustang.


You should have the same pump and bag on your 62 Chrysler wagon as well, if it has a washer system. I've seen a few of these pumps on Ebay advertised for Mustangs as well.
Top of the page Bottom of the page
58 DESOTOS RULE
Posted 2019-03-21 8:17 AM (#579638 - in reply to #579437)
Subject: RE: Installed a Jiffy Jet Washer System



Expert

Posts: 2244
200010010025
Location: The Bat Cave, Fairborn, OH

imopar380 - 2019-03-16 7:07 PM Today I replaced my non-working Trico Co-ordinated Washer System with the much simpler Jiffy Jet system. My Trico system has broken parts, a vacuum leak and parts are pretty much unobtainable. This system was used only on US built 1960 Chrysler and Imperial, plus 1958-1962 Corvettes and a few Cadillacs. The Jiffy Jet was used previous to 1960 and then again in 1961 and later. It's much simpler although the washers aren't coordinated to turn on the wipers when you press the button. This is the first time my washers have worked since i bought the car in 2008. I had a Jiffy Jet electric pump and a friend gave me the washer bag. He has collected an assortment of them over the years from parts cars. This setup is identical to the setup in his 1961 Saratoga. The electric pump was mounted at the bottom of the core support just in line with the bottom of the washer bag. I also ran all new hoses from the bag to the washer nozzles and a new "T" joint where the line separates to go to the nozzles. The bag took a lot of scrubbing with a Scotch Brite pad to get it looking this good.

That's using your thinking cap, Ian.

Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [50 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread



(Delete all cookies set by this site)