The Forward Look Network
The Forward Look Network
Search | Statistics | User Listing Forums | Chat | eBay | Calendars | Albums | Skins | Language
You are logged in as a guest. ( logon | register )

Pump Squeaks After Rebuild
Jump to page : 1
Now viewing page 1 [50 messages per page]
View previous thread :: View next thread
   Forward Look Technical Discussions -> Steering and SuspensionMessage format
 
FINS!
Posted 2020-01-13 11:06 AM (#592856)
Subject: Pump Squeaks After Rebuild


Elite Veteran

Posts: 774
5001001002525
I had the power steering pump rebuilt in my 325. (by Lares) After installing it, it squeaks and has some hard spots. Any ideas?
Top of the page Bottom of the page
wizard
Posted 2020-01-13 12:30 PM (#592862 - in reply to #592856)
Subject: Re: Pump Squeaks After Rebuild



Board Moderator & Exner Expert 10K+

Posts: 12112
500050002000100
Location: Southern Sweden - Sturkö island
What type of pump is it? Is it the slipper type? photos?
Top of the page Bottom of the page
FINS!
Posted 2020-01-13 6:45 PM (#592879 - in reply to #592856)
Subject: RE: Pump Squeaks After Rebuild


Elite Veteran

Posts: 774
5001001002525
It's the Vickers type pump.
Top of the page Bottom of the page
wizard
Posted 2020-01-14 1:00 AM (#592893 - in reply to #592856)
Subject: Re: Pump Squeaks After Rebuild



Board Moderator & Exner Expert 10K+

Posts: 12112
500050002000100
Location: Southern Sweden - Sturkö island
Then I don't have any experience...
Top of the page Bottom of the page
wizard
Posted 2020-01-14 1:01 AM (#592894 - in reply to #592856)
Subject: Re: Pump Squeaks After Rebuild



Board Moderator & Exner Expert 10K+

Posts: 12112
500050002000100
Location: Southern Sweden - Sturkö island
Then I don't have any experience...
Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [50 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread



(Delete all cookies set by this site)