[Chrysler300] Power seat switch 60-62 +
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chrysler300] Power seat switch 60-62 +



Hi all, Had occasion to get into this pretty good, as one direction not working, spent some time on it , thought I would share . Had cleaned and rebuilt clutch thing previously , worked ok . FSM good on that , keep in sync. 
First it is a very rugged switch inside , not too much to go wrong , sliding copper spring loaded shoes connect wires to 12v in various ways . Very clever thing . Three clutches two motor directions for 4 motions .  Red wire is +12 , you can test switch by energizing that wire on the male switch plug , look for output on all other wires at least once for all combinations of up down front back .  The actual logic is complicated and in FSM ,( although not directly ) , you can figure it out . Does not matter in a way , as all turn on at some position or another . Some wires are live in several positions . In my case the yellow was dead. I opened switch by bending back the crimps , and much to my surprise stuff really  flew everywhere ...(!!!!)  springs and contacts . Great despair! Lost one tiny spring of 4 . But after careful examination , by putting body face up in vise and lightly gluing springs into locating holes ( only on top turn of spring  , weatherstrip adhesive) I got it together . Took spring from inside of tiny needle nose plier handle to replace lost one . 
Could find nothing wrong! Contacts look like new. I think what happened is oxidation of (one) contacts ---so vigorous working this switch back and forth 50 times will probably usually fix it ! Slide type contact should clean itself. I added a drop of 75w oil where knob shaft goes in , a cone like thing , moves much better . After reassembly ( took a while to figure out --- but loose contacts have tabs that face away from wire side , toward springs) ; then I noticed solder job by factory was very poor where wires attach to tabs on back  . I resoldered them , yellow was really poor . Might have been the problem . 
Working ok now . Hope this helps somebody frustrated by power seats !! One more 300 item down .. !
John

Sent from my iPhone

------------------------------------
Posted by: John Grady <jkg@xxxxxxxxxxxxxxxxx>
------------------------------------

To send a message to this group, send an email to:
Chrysler300@xxxxxxxxxxxxxxx

To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
go to https://groups.yahoo.com/neo/groups/all/manage/edit

For list server instructions, go to http://www.chrysler300club.com/yahoolist/inst.htm

For archives go to http://www.forwardlook.net/300-archive/search.htm#querylang
------------------------------------

Yahoo Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/Chrysler300/

<*> Your email settings:
    Individual Email | Traditional

<*> To change settings online go to:
    http://groups.yahoo.com/group/Chrysler300/join
    (Yahoo! ID required)

<*> To change settings via email:
    Chrysler300-digest@xxxxxxxxxxxxxxx 
    Chrysler300-fullfeatured@xxxxxxxxxxxxxxx

<*> To unsubscribe from this group, send an email to:
    Chrysler300-unsubscribe@xxxxxxxxxxxxxxx

<*> Your use of Yahoo Groups is subject to:
    https://info.yahoo.com/legal/us/yahoo/utos/terms/



Home Back to the Home of the Forward Look Network Archive Sitemap