RE: [Chrysler300] Voltage Regulator-solid state
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Chrysler300] Voltage Regulator-solid state





John,

 

Thanks for commenting, I was hoping you might chime in with your electrical background.  So, I too have not had the best luck with solid state VR's.  This is actually the 3rd one I've had since about 2003 that's gone flaky.  Yes, it is the small chip type, made in China, on the smallish circuit board.  Looks good, but just doesn't seem to hold up.

 

Drove it about 375 miles yesterday coming back from Malibu from my son's wedding. He and his fiancé (now wife) asked if they could include it in the wedding and have it at the church, so we made it happen.  They had a video crew there catching it all and included a short drive down the Pacific Coast Highway.  I shipped it down there but decided to drive back.  It ran fine but that darn problem of the wildly swinging ammeter started up.  As it got dark the lights were flickering as you would expect, but all of a sudden, the light output dropped.  I was close to home at that point, so I immediately put a volt meter on it when I pulled in.  With the engine running at idle, I measured 12.54 volts at the battery, which is of course, too low.  I turned it off and went to bed.

 

Today, I fired it up and now the voltage reads too high @ 15.10 volts!!  The regulator has gone wacko.  The reason I've stayed with solid state units is that everyone says they will eliminate ammeter bouncing, but I'm not so sure about that.  All comments are welcome!

 

Bob J

 

From: John Grady [mailto:jkg@xxxxxxxxxxxxxxxxx]
Sent: Monday, May 08, 2017 4:16 PM
To: 'Bob Jasinski' <rpjasin@xxxxxxxxxxx>; chrysler300@xxxxxxxxxxxxxxx
Subject: RE: [Chrysler300] Voltage Regulator-solid state

 

Hi Bob,

 

Sort of as you are finding out, IMHO, solid-state low production stuff (usually from China) is just not as good as the mechanical one..that is for sure over the first 60 k miles..Why want solid state? Marketing?

 

Any electrolytic caps inside are rated for 3000 hours, less at high temp, one spike wipes out transistors/ IC’s .  I opened one of the bad ones I had , it was a single custom IC chip glued to the metal can base plate, for a heat sink. 50 cents worth of stuff.  Find an Echelin NOS mechanical, be happy. Bullet proof.

 

Solid state , one wire field,  alternator regulators sold by NAPA are real junk, the one with one red wire hanging out of a box is PURE junk; went thru 3 of those on my 67 dart. . The flickering ammeter is an indication (on the early alternator, mechanical VR ) all is working ok…

 

That being said, the Blue Streak line out of Standard Auto Parts was pretty good, usually. And I think the box is black…Maybe even rock auto…

 

Later B body ones , for one wire alternator (resto ones) should work fine, but no personal experience.  ; do not mix up the two kinds of wiring, VR’s,  or alternator  ---totally different. How many field wires (smaller gauge wires, F1 F2 ,or just an F1 ) leave alternator is the key. (not ground wires).

 

I helped a guy who had ended up with two wire wiring on alternator and regulator on a 65 Imperial, (it had been “converted “ to a two wire alternator, and VR, but then he had alternator trouble, his mechanic had put in the right alternator, and chose to ground the now extra wire, he thought it was a ground, blew up the harness and 3-4 VR’s .Car had sat for 3 years over this. Took a whole day to get sorted out as “wrong” wiring was all nicely hidden in the newly taped harness. Really mixed me up, until I realized what was going on. (colors all wrong on VR ) . Yours is not like that, but beware . Use FSM too , on the colors, locations on VR . Usually different terminal ends  are there, to prevent hook up errors. You can use a later two wire alternator on early cars by grounding one of the field wires (jumper).

 

From: Chrysler300@xxxxxxxxxxxxxxx [mailto:Chrysler300@xxxxxxxxxxxxxxx] On Behalf Of 'Bob Jasinski' rpjasin@xxxxxxxxxxx [Chrysler300]
Sent: Monday, May 08, 2017 6:18 PM
To:
chrysler300@xxxxxxxxxxxxxxx
Subject: [Chrysler300] Voltage Regulator-solid state

 



Does anyone have a suggestion for a source for an original looking voltage regulator that is solid state?  I got one about 12 years ago from John Hertog, but it is now failing.  I know there are a number of solid state replacements available, but I'd like it to look right too.

 

Thanks!

 

Bob J

'61 300G

 





__._,_.___

Posted by: "Bob Jasinski" <rpjasin@xxxxxxxxxxx>


To send a message to this group, send an email to:
Chrysler300@xxxxxxxxxxxxxxx

To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
go to https://groups.yahoo.com/neo/groups/all/manage/edit

For list server instructions, go to http://www.chrysler300club.com/yahoolist/inst.htm

For archives go to http://www.forwardlook.net/300-archive/search.htm#querylang





__,_._,___


Home Back to the Home of the Forward Look Network Archive Sitemap