The Forward Look Network
The Forward Look Network
Search | Statistics | User Listing Forums | Chat | eBay | Calendars | Albums | Skins | Language
You are logged in as a guest. ( logon | register )

Dodge 241 Hemi - First run in a long (unknown) time
Jump to page : 1
Now viewing page 1 [50 messages per page]
View previous thread :: View next thread
   Forward Look NON-Technical Discussions -> 1955-1961 Forward Look MoPar General DiscussionMessage format
 
jboymechanic
Posted 2017-06-12 4:12 PM (#541996)
Subject: Dodge 241 Hemi - First run in a long (unknown) time



Elite Veteran

Posts: 1039
100025
Location: Muskego, WI
First run in well over a decade, getting ready to help a friend put this in his 1954 Dodge Truck. Has the stock truck bell housing and clutch with A-body 4 speed overdrive A833 trans adapted to it. I made the setup myself about 4 years ago and we're finally gaining some momentum on the project.

https://youtu.be/KW8FZmNpzBc
Top of the page Bottom of the page
71charger_fan
Posted 2017-06-15 12:51 PM (#542186 - in reply to #541996)
Subject: Re: Dodge 241 Hemi - First run in a long (unknown) time


Veteran

Posts: 268
1001002525
Location: Frederick, MD
Sounds good. I'd love to have that in my '55 Plymouth.
Top of the page Bottom of the page
jboymechanic
Posted 2017-06-15 1:19 PM (#542187 - in reply to #541996)
Subject: Re: Dodge 241 Hemi - First run in a long (unknown) time



Elite Veteran

Posts: 1039
100025
Location: Muskego, WI
The freeze plugs have since been replaced, water jackets were pretty plugged up with crud, but not the worst I've seen. Hope to clean the block out with some Drano and test the function of our clutch, shifter and transmission next.
Top of the page Bottom of the page
jboymechanic
Posted 2017-07-06 1:25 PM (#543657 - in reply to #541996)
Subject: Re: Dodge 241 Hemi - First run in a long (unknown) time



Elite Veteran

Posts: 1039
100025
Location: Muskego, WI
Update on this motor, we hooked a vacuum gauge up to it and couldn't get more than 10 inches of Hg. Throttle response was terrible. When adjusting the idle mixture screws, one could be bottomed out and have no effect on the idle. Then we started pulling spark plug wires off to see if the motor would stumble, ended up pulling 4 off with no change to idle. The manifold is dual plane, 2 barrel carburetor. The carb was only fueling through one barrel and feeding only the top plane of the intake. As a result, the engine was running on 4 cylinders. It was running smoothly as it was running on every other cylinder in the firing order.

We swapped on a 2 barrel from a 1966 Poly 318 and she really came to life!
Top of the page Bottom of the page
56D500boy
Posted 2017-07-06 4:17 PM (#543661 - in reply to #543657)
Subject: Re: Dodge 241 Hemi - First run in a long (unknown) time



Expert

Posts: 1851
10005001001001002525
Location: Lower Mainland BC
jboymechanic - 2017-07-06 1:25 PM The carb was only fueling through one barrel and feeding only the top plane of the intake. As a result, the engine was running on 4 cylinders. It was running smoothly as it was running on every other cylinder in the firing order.


Careful. FCA's lawyer's might come after you for infringing on the Chrysler Multi-Displacement System (MDS) patents.

LOL.



Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [50 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

Search for anything on eBay!

(Delete all cookies set by this site)