Re: [Chrysler300] Power Steering Pump leak
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chrysler300] Power Steering Pump leak






Hi mike, 
No, I didn't use a torque wrench.  I just pulled to what seemed about right and tightened  the  bolts. It seems ok but I  probably should have used a torque  wrench. 
I like your idea of doubling two of the tools.

Charlie



Sent from Yahoo Mail on Android

On Wed, Jun 15, 2016 at 7:47 PM, Michael Moore mmoore8425@xxxxxxx [Chrysler300]
<Chrysler300-noreply@xxxxxxxxxxxxxxx> wrote:
 

Charlie, I discovered the same thing. Did you torque to 45 ft-lbs? 

It sure seemed like an awful lot.I ended up with two of the belt tightening tools (like one twice as thick0. That seemed to me to be easier to work with (both on the same torque wrench.)
.
Mike Moore
300H 
On Jun 15, 2016, at 8:40 AM, Charlie V cv300g@xxxxxxxxx [Chrysler300] <Chrysler300-noreply@xxxxxxxxxxxxxxx> wrote:

 

The belt tightening tool does work. I also found that its easier if I remove the battery. 


 

Thanks all for the info, I think I'll order a pump just in case.I should
be able to handle removal/disassembly OK, and I'll also order one of
those belt tightening tools.

Don Nissen 300K





__._,_.___

Posted by: Charlie V <cv300g@xxxxxxxxx>


To send a message to this group, send an email to:
Chrysler300@xxxxxxxxxxxxxxx

To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
go to https://groups.yahoo.com/neo/groups/all/manage/edit

For list server instructions, go to http://www.chrysler300club.com/yahoolist/inst.htm

For archives go to http://www.forwardlook.net/300-archive/search.htm#querylang




Visit Your Group
Yahoo! Groups
PrivacyUnsubscribeTerms of Use

__,_._,___


Home Back to the Home of the Forward Look Network Archive Sitemap