Re: [Chrysler300] Leaking Power Steering Pump
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chrysler300] Leaking Power Steering Pump





Hi Don,
I just removed and replaced the reservoirs on two 62 pumps.
The large rubber o ring  could be your problem, but the small gasket between the pump and the reservoir where the attach bolts are could be the source. (I left it out on my first attempt and had a leak) Check to see if one of those bolts has become loose. It's easy to make a new gasket.
If you want to rebuild, try Lares Corporation 800-555-0767.
\Doug Warrener 


From: "Donald Nissen fast-ace@xxxxxxxxxxx [Chrysler300]" <Chrysler300-noreply@xxxxxxxxxxxxxxx>
To: "300 Group" <Chrysler300@xxxxxxxxxxxxxxx>
Sent: Tuesday, June 14, 2016 11:20:06 AM
Subject: [Chrysler300] Leaking Power Steering Pump

 

Hi all, I need some help from the 300K experts, or anyone who knows.
My pump is leaking, small so far. It is not from front seal behind the
pulley. It is also not from either hose. It seems to be wet on the
bottom of were the reservoir meets the pump. Does this mean it is
leaking from the rear of the pump, and the pump needs replacing or is it
the seal between the two? Or is it impossible to tell? All the
rebuilders I have checked so far supply the pump without reservoir and
pulley. Otherwise the power steering is fine-just annoying leak & I
want to get this fixed before Elkhart. Any help greatly appreciated.

Don Nissen, 300K




__._,_.___

Posted by: 2HsandaHeritage@xxxxxxxxxxx


To send a message to this group, send an email to:
Chrysler300@xxxxxxxxxxxxxxx

To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
go to https://groups.yahoo.com/neo/groups/all/manage/edit

For list server instructions, go to http://www.chrysler300club.com/yahoolist/inst.htm

For archives go to http://www.forwardlook.net/300-archive/search.htm#querylang





__,_._,___


Home Back to the Home of the Forward Look Network Archive Sitemap