Re: [Chrysler300] Radiator Hose Clamps
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chrysler300] Radiator Hose Clamps





Agree , all the retro reproduction wire clamps are junk . No spring temper , just bent wire from China . Had same experience , gave up . Many of the originals have been “sprung” by opening them too much takes steel in the wire  beyond steel yield point — never work well again . You do need the right tool to control that . 
Easy to ruin with pliers. 
I do not like look t too much but have taken to using worm drive clamps and breaking off the tail left over , right at the clamp , and putting worm underneath . Looks a lot better than 1” tail hanging off 
Sent from my iPhone

On 30 Jan 2018, at 5:26 pm, plotkin_associates@xxxxxxxxxxx [Chrysler300] <Chrysler300-noreply@xxxxxxxxxxxxxxx> wrote:

Tried to replace the screw type clamps holding the upper and lower radiator hoses in my 64 Chrysler 300K (413 cu in, 4 brl, no a/c). The repro spring type clamps that I bought fit but weren't tight enough to stop antifreeze leakings when the engine was started.  Any one have or know where to get original spring type clamps for a 64 300K that hopefully would have a tighter fit. Used are fine as long as tight. Need 4 of them. Thanks for any help.

Myron 




__._,_.___

Posted by: John Grady <jkg@xxxxxxxxxxxxxxxxx>


To send a message to this group, send an email to:
Chrysler300@xxxxxxxxxxxxxxx

To unsubscribe from this group, send an email to bob@xxxxxxxxxxxxx or
go to https://groups.yahoo.com/neo/groups/all/manage/edit

For list server instructions, go to http://www.chrysler300club.com/yahoolist/inst.htm

For archives go to http://www.forwardlook.net/300-archive/search.htm#querylang





__,_._,___


Home Back to the Home of the Forward Look Network Archive Sitemap


Copyright 2018 The Forward Look Network.  All rights reserved.

Opinions expressed in posts reflect the views of their respective authors.